最近在配置 本地服务器内网穿透的时候,安装本地的rpm包提示如下

error: Failed dependencies:

libc.so.6 is needed by phddns-3.0.2-1.i386 libc.so.6(GLIBC_2.0) is needed by phddns-3.0.2-1.i386 libc.so.6(GLIBC_2.1) is needed by phddns-3.0.2-1.i386 libc.so.6(GLIBC_2.1.3) is needed by phddns-3.0.2-1.i386 libc.so.6(GLIBC_2.3) is needed by phddns-3.0.2-1.i386 libc.so.6(GLIBC_2.3.2) is needed by phddns-3.0.2-1.i386 libdl.so.2 is needed by phddns-3.0.2-1.i386 libgcc_s.so.1 is needed by phddns-3.0.2-1.i386 libgcc_s.so.1(GCC_3.0) is needed by phddns-3.0.2-1.i386 libgcc_s.so.1(GLIBC_2.0) is needed by phddns-3.0.2-1.i386 libm.so.6 is needed by phddns-3.0.2-1.i386 libm.so.6(GLIBC_2.0) is needed by phddns-3.0.2-1.i386 libpthread.so.0 is needed by phddns-3.0.2-1.i386 libpthread.so.0(GLIBC_2.0) is needed by phddns-3.0.2-1.i386 libpthread.so.0(GLIBC_2.1) is needed by phddns-3.0.2-1.i386 libpthread.so.0(GLIBC_2.3.2) is needed by phddns-3.0.2-1.i386 librt.so.1 is needed by phddns-3.0.2-1.i386 librt.so.1(GLIBC_2.2) is needed by phddns-3.0.2-1.i386 libstdc++.so.6 is needed by phddns-3.0.2-1.i386 libstdc++.so.6(CXXABI_1.3) is needed by phddns-3.0.2-1.i386 libstdc++.so.6(GLIBCXX_3.4) is needed by phddns-3.0.2-1.i386 libstdc++.so.6(GLIBCXX_3.4.5) is needed by phddns-3.0.2-1.i386

: Error no dependencies 错误:没有依赖关系。

然而一个一个安装依赖包显然很麻烦,我就偷了个懒,不考虑安装依赖包的情况下直接安装RPM包,但是很遗憾的是没有依赖包的情况下,rpm根本运行不了,然后想到 yum localinstall xxx这个

果断安装成功,当当..


人们在一眨眼间做出的 决策,其内涵远比表相 来的复杂。 《Bink眨眼之间》